ckkl.net
当前位置:首页 >> DEvEl >>

DEvEl

devel 包主要是供开发用,至少包括以下2个东西: 1. 头文件 2. 链接库 有的还含有开发文档或演示代码。 以 glib 和 glib-devel 为例: 如果你安装基于 glib 开发的程序,只需要安装 glib 包就行了。 但是如果你要编译使用了 glib 的源代码,则需要...

devel 英['devl]美['devl] n. 重击 网络 开发包; 开发; 开发工具 双语例句 Independent component analysis ( ICA) is a recently devel-oped method based on higher order statistical analysis. 独立成分分析方法(ICA)是近几年才发展起来的...

指对应软件包的开发包,一般会包括头文件、静态库甚至源码。 仅仅使用这些软件包是不需要安装-devel包的,但如果自己开发的软件需要用到这些软件包中的共享库等等的话就需要安装。 比如zlib库,有些应用依赖于这个库才能正常运行,因此需要安装z...

如果某个程序需要内核提供的一些功能,它就需要内核的 C header 来编译程序,这个时候 linux-devel 里面的东西就用上了。 比如 nvidia 和 ati 的官方显卡驱动,alsa-driver 声卡驱动,他们都需要编译一个放在内核里面运行的模块,编译这个模块就...

linux的安装包一般都是rpm结尾的,你说的这些devel,lib,headers这些不是安装包的格式,而是他们的属性表述。devel代表驱动,lib代表库,headers是一些特殊的软件。

Redhat在封装openssl的时候,把openssl分成了几个部分,执行码部分就是 openssl-1.0.0-27.el6.x86_64 这种包。 openssl-devel-1.0.0-27.el6.x86_64 这个就是包含了头文件,头文件参考,某些库文件等跟开发相关的东西。 mod_ssl-2.2.15-26.el6.x8...

要安装nfs需要依赖:ibnfsidmap.so.0 is needed by nfs-utils-1:1.2.3-26.el6.i686 libtirpc is needed by nfs-utils-1:1.2.3-26.el6.i686 libtirpc.so.1 is needed by nfs-utils-1:1.2.3-26.el6.i686 nfs-utils-lib >= 1.1.0-3 is needed by nf...

一般,在开发测试阶段用debug版本,而上线发布用release版本。 使用Makefile定制编译不同版本,避免修改程序和Makefile文件,将会十分方便。 读了一些资料,找到一个解决方法,Makefile预定义宏与条件判断,结合make预定义变量,进行条件编译。 ...

sudo apt-get install openssl sudo apt-get install libssl-dev RedHat、centos才是openssl-devel

Linux系统中带有devel字样的版本和不带devel的版本的区别是,带devel字样的版本往往用于其他软件的编译过程中,而不带devel字样的才是程序平时运行过程中调用的版本,一个是编译过程中用的,一个是平时运行过程中用的。举个例子吧,比如我曾经用...

网站首页 | 网站地图
All rights reserved Powered by www.ckkl.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com